Please login or register.

Login with username, password and session length
Pages: [1] |   Go Down

Author Topic: Help 86 diplomat  (Read 834 times)

0 Members and 1 Guest are viewing this topic.

robs86

  • Guest
Help 86 diplomat
« on: May 29, 2011, 11:51:55 »

my 86 diplomat started running like crap. I was running great, then started missing, and pinging Always use premium fuel, changer the wires rotor cap and plugs, and it's still the same. low mileage car (80000) sorta strange, any suggestions?
Logged

Dippy.org

  • Advertisement
  • ***

Ice Cold

  • Dippy Oracle
  • *****
  • Offline
  • Frozen Wastelands, Canada
  • Posts: 17563
  • Mopar or No Car
Re: Help 86 diplomat
« Reply #1 on: May 29, 2011, 12:45:33 »

Fuel filter, rusty line, hole in the tank?
Logged
1988 Fifth Ave
1987 Diplomat
1989 Diplomat AHB
1979 Lebaron Medallion 4dr
1979 Lebaron Coupe
1977 Aspen R/T
All drivers.
Too many cars and still looking.

DobaMark

  • Dippy Oracle
  • *****
  • Offline
  • Pittsburgh
  • Posts: 6416
Re: Help 86 diplomat
« Reply #2 on: May 29, 2011, 12:47:06 »

Given the age, even with the low mileage, it's possible it's jumped time.  The 318 in my old 1981 Cordoba did that, ran fine one day next day it pinged like crazy and I had to put a new timing chain in it.
You might want to double check the timing and it it's off unexpectedly check the chain for wear.
Logged

Mike

  • Global Moderator
  • Dippy Oracle
  • *
  • Offline
  • Canada
  • Posts: 9225
Re: Help 86 diplomat
« Reply #3 on: May 29, 2011, 13:51:48 »

It could also be a sensor that went bad or a wire that got disconnected/shorted if you still have the computer, or a disconnected vacuum hose etc.
Logged

MyDodgeDip

  • Dippy Oracle
  • *****
  • Offline
  • Somerville, NJ
  • Posts: 6871
Re: Help 86 diplomat
« Reply #4 on: May 29, 2011, 18:31:47 »

I'd check for vacuum leaks first and re check timing. 
Logged
~Luke
1978 Chrysler Lebaron Coupe, 360-4, Sunroof
+ A Fleet of K cars...

Ice Cold

  • Dippy Oracle
  • *****
  • Offline
  • Frozen Wastelands, Canada
  • Posts: 17563
  • Mopar or No Car
Re: Help 86 diplomat
« Reply #5 on: May 29, 2011, 19:53:53 »

If it's like a sock in the carb, then it's the timing or timing gear. I HATE OEM nylon gears. :x
Logged
1988 Fifth Ave
1987 Diplomat
1989 Diplomat AHB
1979 Lebaron Medallion 4dr
1979 Lebaron Coupe
1977 Aspen R/T
All drivers.
Too many cars and still looking.

fifthcrunch

  • Dippy God
  • ****
  • Offline
  • Posts: 2725
Re: Help 86 diplomat
« Reply #6 on: May 30, 2011, 16:33:19 »

Definitely check timing.  Also, it might be running hot or too lean.  If you haven't changed it, it's computer controlled.  Could be anything that might confuse the computer, such as O2 sensor, carb solenoid, egr  If egr isn't working right, combustion temp can go up.  I believe it has a knock sensor, but I don't think that's the problem
Logged
Pages: [1] |   Go Up